
Introduction to Epanet

Objective:

Introduction to Epanet (water supply simulation software) using a
geo-referenced map.

Part 1
Refreshing of basic hydraulics concept used in Epanet



Hydrostatic pressure
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p = ρ * g * h
p = pressure
ρ = Fluid density (water)
g = Acceleration (gravity)
h = high of water over the point

p = ρ * g * h
p = 1000 kg/m³ * 9.81 m/s² * 10m
p = 98 100 kg/(m*s²)
p = 98 100 N/m²
p = 98.1 kN/m²

Units:
p = 98100 N/m² = 98100 Pa = 0.981 bar = 32.819 foot of water = 10.0034 m of water
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Relative and absolute pressure

pabs = pA + ρ * g * h
● Absolute pressure:      pabs

● Atmospheric pressure: pA
● hydrostatic pressure: ρ * g * h



Flow and velocity in round pipes
Water under pressure (full pipe)

The pipe must be filled
v = Q / A = 4 * Q / (π * d ²)        Q=v*A

● v = velocity    (m / s)
● Q = Flow         (m³ / s)
● A = Surface of the section of the pipe (m2)
● d = Diameter   (m) (d in Epanet (mm)
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Equation of continuity

Q = v / A  = const
● v = velocity m / s
● Q = flow en m³ / s
● A = Pipe section transversal m²

Small diameter, high velocityBig diameter, low velocity
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laminar

turbulent

EPANET considers both types of flows!

Flow types: laminar - turbulent
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● laminar: Re <2000

● transition : 2000 <Re <4000

● turbulent Re> 4000

The simulation with turbulent flow are different than laminar flow

Reynolds number (Re) is used to numerically describe the type of flow

● laminar
● transition
● turbulent
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Viscosity
● A liquid with high viscosity resists deformation (i.e. Honey).
● Viscosity of water depends on the temperature

-- with 20 ° C: ν = 1,01 * 10-6 m² / s
-- with 10 ° C: ν = 1,31 * 10-6 m² / s

FOR EPANET:
If water temperature is not around 20°C
you could consider it in Epanet in the
parameter of the “relative viscosity”
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i.e desert situation
during day

Temperatura agua Viscosidad relativa al
agua de 20°C Temperatura agua Viscosidad relativa al

agua de 20°C Temperatura agua Viscosidad relativa al
agua de 20°C Temperatura agua Viscosidad relativa al

agua de 20°C

1 1.72 26 0.87 51 0.586 76 0.436

2 1.666 27 0.852 52 0.58 77 0.43

3 1.612 28 0.833 53 0.574 78 0.424

4 1.558 29 0.815 54 0.568 79 0.419

5 1.504 30 0.796 55 0.562 80 0.413

6 1.463 31 0.782 56 0.556 81 0.407

7 1.421 32 0.767 57 0.55 82 0.401

8 1.38 33 0.753 58 0.544 83 0.395

9 1.338 34 0.738 59 0.538 84 0.389

10 1.297 35 0.724 60 0.532 85 0.383

11 1.265 36 0.709 61 0.526 86 0.377

12 1.232 37 0.695 62 0.52 87 0.371

13 1.2 38 0.68 63 0.514 88 0.365

14 1.167 39 0.666 64 0.508 89 0.359

15 1.135 40 0.651 65 0.502 90 0.353

16 1.108 41 0.646 66 0.496 91 0.347

17 1.081 42 0.64 67 0.49 92 0.341

18 1.054 43 0.634 68 0.484 93 0.335

19 1.027 44 0.628 69 0.478 94 0.329

20 1 45 0.622 70 0.472 95 0.323

21 0.978 46 0.616 71 0.466 96 0.317

22 0.956 47 0.61 72 0.46 97 0.311

23 0.933 48 0.604 73 0.454 98 0.305

24 0.911 49 0.598 74 0.448 99 0.299

25 0.889 50 0.592 75 0.442 100 0.293

Water
Temp.

°C

Rel.
Viscosity
to water
of 20°C

26 0.87
27 0.852
28 0.833

Relative viscosity in Epanet
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Friction loss along pipes

Energy is dissipated due to friction of water
(particle)
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Friction loss, Darcy-Weisbach

● hf = friction loss mm
● f = friction parameter (non dimension) (Darcy) -> Moody Diagram
● l = length of pipe m
● d = diameter of pipe en m
● v = velocity of water m / s
● g = 9,81 m / s ²
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Friction loss, Hazen-Williams

where:

HL = friction loss m
Q = flow  m3/s
L = length of pipe m
d = Diameter of pipe m
C = coefficient (Hazen-Williams C-factor) no dimension
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Friction loss, Chezy-Manning

Where

HL = friction loss m
Q = flow
L = length of pipe m
d = diameter of pipe m
n = friction coefficient of Manning no dimension
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The Hazen-Williams formula is the most commonly used headloss formula in the US.
It cannot be used for liquids other than water and was originally developed for
turbulent flow only.

The Darcy-Weisbach formula is the most theoretically correct. It applies over all flow
regimes and to all liquids.

The Chezy-Manning formula is more commonly used for open channel flow.



Chezy-Manning

Darcy-Weisbach

Hazen-Williams
Q = v*A
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Friction loss

Darcy-Weisbach
(mm)

0.25908
0.3048 – 3.048

0.01524
0.001524
0.04572

0
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Minor losses or local losses

● Minor losses
i.e. Bends, fitting, valves, etc.
Below the coefficient to consider in the setup of Epanet:
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Flow classification: stable / unstable

● stable flow doesn’t change over the time
● unstable flow changes over the time

I.e. Parameter that could change:
● Speed
● Flow
● Pressure
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Flow classification: stable / unstable

● EPANET simulates ONLY constant flow

● Water hammer is an example of unstable flows in pipe
● The simulation over time allows to analyse different flows in the
pipe (pattern)
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Fire fighting, fire water

In urban setting think about water for fire fighters

A regulation might exist
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Limitation of Epanet

With Epanet is not possible to simulate open channels

Typical open channels:
● river
● Sewer
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Limitation of Epanet

Epanet doesn't  have plugins
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Thanks
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Objectives:
We develop a very simple water supply composed by:
1. Source (spring)
2. Pump from spring to “elevated” reservoir (25m3)
3. Gravity distribution to the village (or refugees camp)
4. Distribution points in the village with a given demand

Introduction to Epanet

Part 2, developing a simple network with Epanet and run
a simple analysis

Existing data
1. Spring yield and ground elevation
2. Pump performance data
3. Nodes location and elevation
4. Type and length of pipe
5. Elevation, type and size of reservoir
6. Average water demand at water distribution points over 24 hr (daily water consumption)
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Introduction to Epanet
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Necessary data related to the Epanet network
Junction Elevation (m) Information

J1 913 Settlement 2; 20 families; 4’000 l/d; 0.0463 l/s
J2 912 Settlement 3; 40 families; 8’000 l/d; 0.0926 l/s
J3 915 Settlement 4; 60 families; 12’000 l/d; 0.139 l/s
J4 910 No demand; joint control valve
J5 916 Settlement 1; 50 families; 10’000 l/d; 0.115 l/s

TOTAL 170 families, 850 individuals, 34’000 l/d, 0.395 l/s

Tank 930
Round reservoir, 25.1 m3, 4m diameter, 2.5m wall height, ground elevation 930m
(inlet), Elevation overflow 932m.

Spring (R1) 890 Good water quality, seasonal variation on yield, max 15m3/h min 11m3/h

Pump (Pu1) 890

NB 32-200.1/207 A-F-A-BAQE (6m3/h, h=70m)
located few meter from spring (see Grundfos webcaps for selection,
www.grundfos.com)

Pipes uPVC
Pi1 140.1 m (from pump)
Pi2 340.0m
Pi3 185.4m
Pi4 198.2m
Pi5 62.5m
Pi6 124.3m

Introduction to Epanet
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Pump specification

Introduction to Epanet
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uPVC pipes
Code ND Pressure IntD C Pressure Thickness

(mm) Bar (mm) m H2O mm (max)
P20-16 20 16 17.0 140 162.56 1.5
P25-12 25 12.5 22.0 140 127 1.5
P25-16 25 16 21.2 140 162.56 1.9
P32-10 32 10 28.8 140 101.6 1.6
P32-12 32 12.5 28.2 140 127 1.9
P32-16 32 16 27.2 140 162.56 2.4
P40-6 40 6.3 37.0 140 64.01 1.5
P40-10 40 10 36.2 140 101.6 1.9
P40-12 40 12.5 35.2 140 127 2.4
P40-16 40 16 34.0 140 162.56 3
P50-6 50 6.3 46.8 140 64.01 1.6
P50-10 50 10 45.2 140 101.6 2.4
P50-12 50 12.5 44.0 140 127 3
P50-16 50 16 42.6 140 162.56 3.7
P63-5 63 6 59.2 140 60.96 1.9
P63-6 63 6.3 59.0 140 64.01 2
P63-10 63 10 57.0 140 101.6 3
P63-12 63 12.5 55.4 140 127 3.8
P63-16 63 16 53.6 140 162.56 4.7
P75-5 75 6 70.6 140 60.96 2.2
P75-6 75 6.3 70.4 140 64.01 2.3
P75-10 75 10 67.8 140 101.6 3.6
P75-12 75 12.5 66.0 140 127 4.5
P75-16 75 16 63.8 140 162.56 5.6
P90-5 90 6 84.6 140 60.96 2.7
P90-6 90 6.3 84.4 140 64.01 2.8
P90-10 90 10 81.4 140 101.6 4.3
P90-12 90 12.5 79.2 140 127 5.4
P90-16 90 16 76.6 140 162.56 6.7
P110-6 110 6.3 104.6 140 64.01 2.7
P110-10 110 10 101.6 140 101.60 4.2
P110-12 110 12.5 99.4 140 127 5.3
P110-16 110 16 96.8 140 162.56 6.6
P125-6 125 6.3 118.8 140 64.01 3.1
P125-10 125 10 115.4 140 101.60 4.8
P125-12 125 12.5 113.0 140 127 6

It is important to know the
type/brand and their properties
of the pipes you are using.

Providers usually have that
information.

Introduction to Epanet
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Download and installation of Epanet
1.Download Epanet at http://epanet.de/
2.Install Epanet (works in Windows, Apple, Linux) in several
languages

Epanet is free program, developed (v1 2003), no plugins possible.

There are many other similar programs like WaterCad (commercial),
Branch (open source in DOS), WatDis (free with plugins in CD) and
others.

Introduction to Epanet
Water supply schema example
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Basic main configuration of Epanet

Defaults / ID labels
1.Open Epanet
2.Select Project| Default
3.ID labels

Set the parameters accordantly

Introduction to Epanet
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Program configuration

Defaults / Properties
4. Select the default parameter as per convenience

Introduction to Epanet
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Program configuration

Defaults / Hydraulics
5. In the windows “Hydraulics” select “Flow Units”
with the unity you prefer i.e LPS (liter per second)

Introduction to Epanet
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The Hazen-Williams formula is the most
commonly used head loss formula in the US. It
cannot be used for liquids other than water and
was originally developed for turbulent flow only.

The Darcy-Weisbach formula is the most
theoretically correct. It applies over all flow
regimes and to all liquids.

The Chezy-Manning formula is more commonly
used for open channel flow.

Program configuration

Defaults / Hydraulics
6. Select the head loss formula you prefer

a) Hazen-Williams (H-W)
b) Darcy-Weisbach (D-W)
c) Chezy-Manning (C-M)

Introduction to Epanet
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Program configuration
7. Put the relative viscosity in relation to the average temperature

Save all as default for all projects

Introduction to Epanet

Temperatura
agua

Viscosidad
relativa al agua

de 20°C

Temperatura
agua

Viscosidad
relativa al agua

de 20°C

Temperatura
agua

Viscosidad
relativa al agua

de 20°C

Temperatura
agua

Viscosidad
relativa al agua

de 20°C

1 1.72 26 0.87 51 0.586 76 0.436
2 1.666 27 0.852 52 0.58 77 0.43
3 1.612 28 0.833 53 0.574 78 0.424
4 1.558 29 0.815 54 0.568 79 0.419
5 1.504 30 0.796 55 0.562 80 0.413
6 1.463 31 0.782 56 0.556 81 0.407
7 1.421 32 0.767 57 0.55 82 0.401
8 1.38 33 0.753 58 0.544 83 0.395
9 1.338 34 0.738 59 0.538 84 0.389

10 1.297 35 0.724 60 0.532 85 0.383
11 1.265 36 0.709 61 0.526 86 0.377
12 1.232 37 0.695 62 0.52 87 0.371
13 1.2 38 0.68 63 0.514 88 0.365
14 1.167 39 0.666 64 0.508 89 0.359
15 1.135 40 0.651 65 0.502 90 0.353
16 1.108 41 0.646 66 0.496 91 0.347
17 1.081 42 0.64 67 0.49 92 0.341
18 1.054 43 0.634 68 0.484 93 0.335
19 1.027 44 0.628 69 0.478 94 0.329
20 1 45 0.622 70 0.472 95 0.323
21 0.978 46 0.616 71 0.466 96 0.317
22 0.956 47 0.61 72 0.46 97 0.311
23 0.933 48 0.604 73 0.454 98 0.305
24 0.911 49 0.598 74 0.448 99 0.299
25 0.889 50 0.592 75 0.442 100 0.293
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Configuration of map (layout)

1.Select View | Options.
2.Select Notation (it displays the name of the items like link, joints, pump, reservoir, etc.)
3.Select Symbols (it displays all the icons of the network)
4.Rest of option are self explaining

Introduction to Epanet
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1. Select View / backdrop
2. Load (select example-emf.emf
(CD\Epanet Exercise\example-emf.emf)

NOTE:
•The map is not geo-reference yet.
• Auto-length is off.
•Best extension for backdrop map is
*.emf (best resolution)

The development and sizing of the map
will be shown later if time allows

Introduction to Epanet
Insert the backdrop map
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Drawing the
network
1. Add “reservoir
at the spring.

(if the toolbar is not
visible View ->
Toolbars ->Map).

Introduction to Epanet
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Introduction to Epanet

Drawing the
network
Eventually zoom in
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Drawing the network
1.Click twice on the R1 and the parameters setup of the spring (reservoir) appears

Introduction to Epanet

Coordinates do not play a role yet
Important you put the elevation (*Total Head)
(in meter) of the outlet of the spring.

(considering the dropdown in case of a BH)



Drawing the network
1. Add “Junctions”
2. Set parameters
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Drawing the network

2. Set parameters for the junctions
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Drawing the network
1. Add “Tank”
2. Set parameters

19
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Drawing the network

2. Set parameters for the reservoir

Initial water level in the reservoir 1m
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Introduction to Epanet

Volume of round tank:
2m X 2m X 3.14 X 2m (height) =25.13m3

Ev. fire reserve!



Drawing the network
Adding the pump

In Epanet pumps are
delimitated by two
Junctions

(zoom in)
Add a new junction (J6) and
between spring (R1) and J6
insert the pump            (Pu1)
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Adding the Pump
Insert parameter for the Junction (J6) and Pump
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Create the Pump curve 1
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Introduction to Epanet

Pump curve taken from the graphic
Curve can be saved for future use



Drawing the network
Adding the Pump

Insert the parameters for pump (Pu1)
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This number must correspond
to the pump curve number

If you plan to calculate the power
consumption and power cost fill the
parameters



Drawing the network
Adding the pipes
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Draw pipe      from J6 to J4 (zoom in)



Drawing the network
Adding the pipes
Insert parameters for pipe (Pi1)
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Estimate the diameter with
Q=vA  v=Q/A, A=Q/v (v ~ 1-2 m/s)

Roughness depends on type/age of pipe
and used formula

Length given

check valve restricting flow to one
direction

Note: Firefighters’ regulation Might limit the
size



Drawing the network
Adding the rest of the links
(pipes)
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Drawing the network Insert parameters for pipes
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Running the system (single analysis)
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If system desn‘t
work, error
message will be
displayed and
source of error
explained



Running the system (single analysis)
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You can display / hide
the map in view menu.

You can display
several characteristics
of the system i.e.
velocity in pipes and
pressure at junctions.

Select the browser on
map, and fly with the
mouse over the
concerned item.



Running the system (single analysis)
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Read the full report for full
understanding of the system



Running the system (single analysis)
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Introduction to Epanet

The single analysis helps you to identify the main characteristics and
ev. misstakes on the system, but doesn't give you a realistic
overview of the behaviour of your system over time.

An analysis over time (i.e. 3 days; 72 hs) helps you to understand
better the system.

For such analysis, we need to develop pattern (behaviour changes
over time)

This after the break

Thanks
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Introduction to Epanet

The network previously developped was simulated in a single time period. The demand
and the pump behaviour was considered as constant over time. A rather unrealistic
situation!

In reality, the demand varies during the day (i.e. with peak’s demand in the morning
between 6 and 12 and afternoon from 18 to 22) and the pump works only max 6 hours in
a day.

Part 3, developing a simulation over time with Epanet

Demand pattern

time

de
m

an
d average
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•Epanet allows simulation of constant flow, only

•Therefore, a simulation over longer time with different
constant flows allows to analyse different behaviours of the
same network.

•For this purpose we have to create time pattern.
Pattern for the demand
Pattern for the pump’s running times

Simulation over a time
Introduction to Epanet
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For our demand example, a 2 hours long pattern is used (24hr / 2 = 12 hrs period
time. With this pattern you can modify the behaviours max 12 times during the day.

Simulation over a time
Introduction to Epanet

time

de
m

an
d
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Open with Epanet your previous exercise and save it with a different name, i.e.
example time analysis.

Simulation over a time
Introduction to Epanet
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1. Select Options - Times from Data Browser -> Edit
Simulation over a time (Pattern Time Step)

Introduction to Epanet
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3. Write 2 for the value of “Pattern Time
Step”

Every 2 hours the behaviour changes. It can be from 1 to
12

Simulation over a time
Introduction to Epanet



7

4. Write 72 (hours, 3 days) in “Total Duration” field. This
will be the period length of the simulation.

Simulation over a time
Introduction to Epanet
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Develop the time pattern
1. Select in the Browser / Patterns and add a new pattern

Simulation over a time
Introduction to Epanet
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The Pattern Editor will appear, with per default pattern ID 1.
You can add a description (optional)

Simulation over a time
Introduction to Epanet
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You will add the multiplier of the demand in function of the estimated behaviour
Simulation over a time

Introduction to Epanet

Average of pattern must be „1“
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Introduction to Epanet

For each junction where there is a demand you must specify the pattern
J1, J2, J3 and J5
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Pattern for the pumping time
We assume that the pump pumps once a day for 6 hours. It starts at 8.00 and stops at 14.00.
Add a second Pattern for the pump (Pattern 2)

Introduction to Epanet

Average must not be 1 as like the demand
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Insert the pattern n° at the pump parameter

Introduction to Epanet
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Run the analysis

Introduction to Epanet

OK to see the error

See Epanet Manual page 37 for error message
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Introduction to Epanet
Look at the graph for the tank T1 clicking
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Introduction to Epanet
Evidentely, the tank is overfilled at 10.00 and 32.00 hr is empty

In this case, either you make a bigger tank or or change the pump Pattern.
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Introduction to Epanet
A) Make the tank bigger (Hmax 2.2m Volume 27.6m3)
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Introduction to Epanet
B) Change the pattern of the pump
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Introduction to Epanet

Each element of the network can be analized over time, grafically or with report/tables

Pressure behaviour at Junctions Demand behaviour at Junctions
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Introduction to Epanet
Full report

Table report
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Introduction to Epanet
Note:

Valves are not installed in this example.
Valves need to be installed between two Junctions
Epantet considers 6 types of valves:

•PRV Pressure Reducing Valve
•PSV Pressure Sustaininb Valve
•PBV Pressure Breaker valve
•FCV Flow Control Valve
•TCV Throttle Control Valves
•GPV General Purpose Valve

For setting and info about the use and parameters of the
valves see Epanet user manual

Flow control valve are included in the parameter of the pipes
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Introduction to Epanet
Note:         Fire Water request:

To determine the maximum flow available
at a particular pressure, set the emitter
coefficient at the node to a large value
(e.g., 100 times the maximum expected
flow) to the node's elevation. After running
the analysis, the available fire flow equals
the actual demand reported for the node
minus any consumer demand that was
assigned to it.

Each country might have its own
regulation!

Script, Zurcher Hochschule für Angewanhte Wissenshaften, Wintertur
Trinkwasserversorgung, Page 29
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Introduction to Epanet

Thanks



Backdrop map for Epanet

Objective:

Produce a back drop map for Epanet

•A map is existing, you want to make the backdrop and introduce it (not geo – referenced) in
Epanet



Geo-reference Epanet with qGis

• Scan the map and save it in *.Jpeg format.
• Open it with Irfanview* and save it as *.emf format
(you might use other software)

emf format = Enhanced Windows Metafile
metafiles work better since they will not loose resolution when re-scaled.

*Irfanview = Free software at www.irfanview.com (available in CD, software folder)
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Insert the backdrop map

1.Select New / backdrop
2.Load (select example.emf)

NOTE:
•The map is not geo-
reference yet.
• Auto-length is off.
•Best extension for backdrop
map is *.emf (best
resolution)

Introduction to Epanet

Thanks
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Geo-reference backdrop map in Epanet

Objective:

Introduce a geo-referenced backdrop map in Epanet and
use auto-length on for drawing the network
•You have the map with scale bar on paper and scanned.

•You do not have shape files and do not know how to use GIS (time to learn it ).

•You want to use the back drop map and draw the junctions and pipes direct into Epanet using
auto-length on without typing (knowing) the exact coordinates of the points and the length of the
pipes.

•Elevation of the junctions is either known or the map has contour lines.
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Geo-reference backdrop map in Epanet

Step1
Open the scanned map with any raster graphic editor (i.e. MS
paint, Photoshop)
The scale bar MUST be visible
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Geo-reference backdrop map in Epanet

Step2
Select with select tool the scale bar as precise as you can (zoom
in as best you can) and copy the selection (alt ctrl c).
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Geo-reference backdrop map in Epanet

Step3
Paste the selection (alt ctrl v) as shown below
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Geo-reference backdrop map in Epanet

Step4
Rotate the selected scale bar of 90° and paste it as below
Now you have the dimension of the map (x=800m X y=500m)
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Geo-reference backdrop map in Epanet

Step5
Save the image
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Geo-reference backdrop map in Epanet

Step6
Open the image with irfanview and crop it exactly as the
dimensions (800m x 500m)
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Geo-reference backdrop map in Epanet

Step7
Save it in *.emf format
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Geo-reference backdrop map in Epanet

Step8
Open Epanet and insert the dimension of the backdrop map in
Epanet as seen before (View -> Map Dimension)

800
500

0

0
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Geo-reference backdrop map in Epanet

Step8
Insert the map and switch auto-length on (right click on left bottom)
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Geo-reference backdrop map in Epanet

Step9
Crosscheck the correctness of the length with a new pipe on the scale bar or a known length.
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Geo-reference backdrop map in Epanet

Note:

•The elevation of the junctions must be known and inserted
manually into Epanet at each element.

•This system is not precise, but in case you do not have the shape
files it is still a way to make the simulation.

Thanks
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Geo-reference backdrop map in Epanet

Objective:

Introduce a geo-referenced backdrop map in Epanet and
use auto-length for drawing the network

•You have basic knowledge of GIS (i.e qGis or Global Mapper).

•You have the map in a GIS software (i.e. qGis) with respective shape files.

•You want to draw the junctions and pipes direct into Epanet using auto-length on without typing
the exact coordinates of the points and the length of the pipe.

•You need a software for the transformation of Longitude/Latitude (degrees) coordinates into UTM
(meters) coordinates. (i.e. Global Mapper).
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Geo-reference backdrop map in Epanet

Step1
Install Global Mapper (1) in your PC and
Reproduce the map with it.

Needed shape files:
•Spring.shp
•Junction.shp
•Pipesnews.shp
•Tank.shp
•Settlement.shp
•Road.shp
•Settlement.shp
•Contour 5m.shp
(1)
•Global Mapper is a commercial GIS software (http://www.globalmapper.com/)
•Evaluation is free for 30 days. CD\Software\Global Mapper 15
•Cracked version available in P2P network
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Geo-reference backdrop map in Epanet
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Geo-reference backdrop map in Epanet

Make a comprehensive map with style and labels
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Geo-reference backdrop map in Epanet

Step2

Convert the Global Mapper map

from Geographical Coordinates (Latitude/Longitude) into
UTM(1) Coordinates (Meters)

(1) The Universal Transverse Mercator (UTM) conformal projection uses a 2-dimensional
Cartesian coordinate system to give locations on the surface of the Earth. Like the
traditional method of latitude and longitude, it is a horizontal position representation.
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Geo-reference backdrop map in Epanet

Tools -> Configure ->
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Geo-reference backdrop map in Epanet

Tools -> Configure -> Projection UTM
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Geo-reference backdrop map in Epanet

Tools -> Configure -> Projection -> UTM ->
Zone 32 Northern Hemisphere ->
Planar Units „Meters“ ->
OK

UTM coordinates
Zone: check in WEB
Datum: WGS84
Planar unit: Meter

Zone to be defined with Web
(Google search “Place UTM Zone”
i.e UTM Olivone Zone)
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Geo-reference backdrop map in Epanet

Tools -> Configure -> Projection -> UTM -> OK

The map changes slightly
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Geo-reference backdrop map in Epanet

Step3
Look at the characteristic of the map, copy to clipboard and save it in a editing
file (i.e word, notepad or write). View -> Properties
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Geo-reference backdrop map in Epanet

Saved in a text file
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Geo-reference backdrop map in Epanet

Step4
Capture screen contempt to image (Jpeg) and save it (i.e. MapGlobalMapper.jpg)
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Geo-reference backdrop map in Epanet

Step5
Convert image (Jpeg) to *. emf as before

Open it with Irfanview* and save it into *.emf format

emf format = Enhanced Windows Metafile
metafiles work better since they will not loose resolution when re-scaled.

*Irfanview = Free software at www.irfanview.com
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Geo-reference backdrop map in Epanet

Step6
In Epanet, configure the dimension of you background map
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Geo-reference backdrop map in Epanet

Step6
Open Epanet -> View -> Dimension
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Geo-reference backdrop map in Epanet

Step6
Open Epanet -> View -> Dimension -> Meter



17

Geo-reference Epanet with qGis

Step 7:

•Insert map extension coordinates per text file into Epanet
(copy&paste)
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Geo-reference Epanet with qGis

Step 8:

•Insert map backdrop (View ->Backdrop -> load)
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Geo-reference Epanet with qGis

Select your *.emf map
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Geo-reference Epanet with qGis

Step 9:
Turn auto length on (with right click)



21

Geo-reference Epanet with qGis

Step 10:
•Verify if your backdrop map is correctly place and if auto-length works.
•Zoom in into the scale bar
•Put 2 junctions at the extremities of the scale bar
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Geo-reference Epanet with qGis

Step 11:
•Connect the two junctions with a pipe and see the length (it should be around 350m like
the scale bar.

Thanks

Before to draw your
network do not forget
to verify if the
parameters of Epanet
are set as you wish.
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Use of Epanet within qGis (plug-in GHydraulics)

Objective:

Introduction of GHydrauilcs, the Epanet plug-in for qGIS

•You have good knowledge of qGis (free and open source at www.qgis.org)

•You have installed qGis in your PC

•You have displayed the map in qGis

•You have internet connection

NOTE:
This is not an introduction of qGis.
•The plugin GHydraulics is not fully functional yet, it has apparently some bugs.
•The following presentation is an introduction that will allow you to make a backdropmap.
•In the future the plugin might be fully functional.
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Use of Epanet within qGis (plug-in GHydraulics)

Step1
Download and install the Epanet plugin in qGIS (GHydraulics)

Plugins -> Manage
and install plugins…

Software in CD\Software\qGIS
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Use of Epanet within qGis (plug-in GHydraulics)

Select “not installed”
Search for GHydraulics
-> install plugin -> OK
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Use of Epanet within qGis (plug-in GHydraulics)

Step2
Display the map of the network in qGis (CD -> GIS directory -> Exercise)
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Use of Epanet within qGis (plug-in GHydraulics)

Step3
Plugins -> GHydraulics -> Settings
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Use of Epanet within qGis (plug-in GHydraulics)

Step4
Drop the concerned unused shape files into the Model Elements
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Use of Epanet within qGis (plug-in GHydraulics)

Step4
Drop the concerned unused shape files into the Model Elements

Note:
Element “Reservoir” is
Currently not working
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Use of Epanet within qGis (plug-in GHydraulics)

Step5
Select the template. Available only D-W cmd, D-W lps, H-W gpm
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Use of Epanet within qGis (plug-in GHydraulics)

Step6
Make Epanet model

Plugins -> GHydraulics
-> Make Epanet model

Yes, this will change the field of the shape files in order to make it compatible
with Epanet
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Use of Epanet within qGis (plug-in GHydraulics)

This error is given most probably due to a bug in the plugin
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Use of Epanet within qGis (plug-in GHydraulics)

The shape files have been changed automatically and new
columns have been added in order to make it compatible with
Epanet

Tank
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Use of Epanet within qGis (plug-in GHydraulics)

Spring / Reservoir

Junctions
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Use of Epanet within qGis (plug-in GHydraulics)

Pipes
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Use of Epanet within qGis (plug-in GHydraulics)

Note:
For automatic length column (in case you do not have it):
Open attribute table of Pipes
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Use of Epanet within qGis (plug-in GHydraulics)

Toggle editing mode and click field calculator
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Use of Epanet within qGis (plug-in GHydraulics)

Write “LENGTH” ,
real 10 precision 2
and click twice on
Geometry ->
$Length -> OK
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Use of Epanet within qGis (plug-in GHydraulics)

You should get the column “LENGTH” with the automatic length
inserted
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Use of Epanet within qGis (plug-in GHydraulics)

Step7
Fill the missing parameter into the attributes and delete
unnecessary columns

Tank
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Use of Epanet within qGis (plug-in GHydraulics)

Spring

Junctions
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Use of Epanet within qGis (plug-in GHydraulics)

Pipes
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Use of Epanet within qGis (plug-in GHydraulics)

Step7
Un toggle (save) the open layers
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Use of Epanet within qGis (plug-in GHydraulics)

Step8
Write Epanet file (to be opened later directly with Epanet)

Plugins -> GHydraulics
-> write Epanet inp file
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Use of Epanet within qGis (plug-in GHydraulics)

Step10
Open the saved inp file with Epanet (CD Epanet Exercise folder -> ExerciseEpanetqGis)
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Use of Epanet within qGis (plug-in GHydraulics)

Since the plugin is not complete you will not have the tank (it is
Taken as reservoir)

You must adjust the Epanet file as previously shown and run it
Add pump, pattern, reservoir and missing info.

END
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Tools around Epanet

Objective:

Overview of other tools around Epanet that might be
interesting.

NOTE:
Most of those tools are self explanatory and very easy. Just play with them!

I did not test all of them!
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Tools around Epanet

at http://www.zonums.com/epanet_cat.html

• Epanet Z: Display Yahoo Maps, Google Maps and VE imagery as a background.

• EpaElevation: Find missing elevation of points online.

• Epa2Gis: Transport Epanet projects to a GIS environment using thematic layers.

• Shp2Epa: Create Epanet inp files from ESRI shapefiles. Utilize GIS data as input for Epanet projects.

• Net2Epa: Create Epanet INP files online using Google Maps. Digitize over a Satellite, Map or Hybrid map to
create Epanet Network Maps.

• Gpx2Epa: Create Epanet INP files online from data collected with a GPS unit.

• Epa2kmz: Visualize and share Epanet projects on Google Earth.

• Excel2Epa: Create INP Network files for Epanet from data contained on an Excel sheet.

• Kml2Epanet: Utilize Google Earth Imagery to create the network map, then load the project into Epanet.
Kml2Epanet converts kml files to inp.
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Tools around Epanet

Extends processing framework to models the hydraulic and water quality behavior of
water distribution piping systems.
This plugin lets you model hydraulic network for water and run simulations to get water
pressure informations and more.

See a demo screencast here :
https://vimeo.com/87754967

This plugin looks very professional and complete.
It is free but do not have tutorial unless you pay for a training.

In case you have a tutorial or info aout it, pls share with the WASH unit.

Qgis plugin qGisEpanet https://github.com/Oslandia/qgis-epanet
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Tools around Epanet

Do you want to see the video of Epanet plugin?

1min 45 sec
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Thanks
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Elevations issues

Objective:

Find the most precise elevation with available tools in the
field/office

•GPS
•Topographic maps / cadaster if available
•Online maps Google Earth
•Online tools
•Map analysis (Global Digital Elevation Model Aster GDem)
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1 Elevation from GPS:

GPS give very imprecise
elevations. Do not trust GPS
elevation
(+/-23meters with a DOP of 1 for 95%
confidence).

i.e. Tank 922m

Elevations issues
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Elevations issues

2 Elevation from Google Earth:

Select your point in Google Earth and look right down the
elevation

i.e. Tank 921 m
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Elevations issues

3 Elevation from topographic maps:

Use topo maps if available (oft online)

i.e. Tank 919 m
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Elevations issues

4 Elevation from cadastre if available:

i.e. Reservoir 919.8 m
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Elevations issues

5 Elevation from online tools:
http://www.freemaptools.com/elevation-finder.htm

i.e. Tank 919.69 m
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Elevations issues

6 Global Digital Elevation Model Aster GDem
•Open Global Mapper
•Open the shape files of the junctions/reservoir/tanks/settlements
•Download online data (Aster GDEM) need internet connection without proxy, if proxy (UN, Ambassy) go
to http://gdem.ersdac.jspacesystems.or.jp/ on in a internet café
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Elevations issues

6 Global Digital Elevation Model Aster GDem
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Elevations issues

6 Global Digital Elevation Model Aster GDem

Analyses -> Generate contours (from Terrain Grid)



10

Elevations issues

6 Global Digital Elevation Model Aster GDem

Contour interval 1m
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Elevations issues

6 Global Digital Elevation Model Aster GDem

Contour bounds
All visible data on the screen
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Elevations issues

6 Global Digital Elevation Model Aster GDem
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Elevations issues

6 Global Digital Elevation Model Aster GDem

Open control Center
Untick the AsterGdem layer
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Elevations issues

6 Global Digital Elevation Model Aster GDem

Zoom in to the point and
Determine the elevation
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Elevations issues

6 Global Digital Elevation Model Aster GDem

i.e. Reservoir 929.8 m

END


